Start a new topic

Publish Option (Reposted From Previous ECE Forum)

I’m running Cadworx 2014 P&ID Version l.108.0.0 AutoCad 2014 SP1

If I plot a single sheet, all of my electrical lines print fine, but when I try to publish a group of drawings, the System Link line prints the dashed lines but not the little circle between them. What I have tried, as recommended by ECE is to reload the CFM file:

Type LT in the command line, Click Load, File, then select the CFM file from C:/Cadworx 2014/PID/Support/CFM. Open, select the System Link line, then click on Reload, then regen drawing.

Yet when I publish the drawings even after performing this task on the first drawing, they all print with the circle missing.

Thanks, Dave

Note: Moved From Old Forum


This has something to do with the CTB settings within the Plot Style Manager. 

Can you please send us the PDF version of what is coming out now at

Thank you,

Elvedin Okic

After doing some research online, I found this and it worked.

1. Copied “CFM.SHX” from : C:\CADWorx 2014\P&ID\Support

2. Pasted “CFM.SHX” to : C:\Users\”user ID”\AppData\Roaming\Autodesk\AutoCAD 2014\R19.0\enu\Support

For whatever reason, the System Line Link circles don’t always plot out when I use the Publish option for multiple drawings. I thought I had it figured out as seen from my previous post, but today it didn’t work. Though I followed my own steps, I couldn’t get it to work, so in desperation I reloaded the line type, re-copied all of the CFM files, shut down CadWorx P&ID and then restarted it back up. After 45 minutes of trying different angles it finally worked. The frustration is that it keeps failing to work properly and I don’t know how I fixed it today and I don’t know if it will fail tomorrow. Any ideas at this time would be greatly appreciated.

Thank you.

Login to post a comment
How to report Trademark or CopyRight Violations