CADWorx 2018 is not compatible with BricsCAD 2018 until they release service pack 1 for CADWorx 2018.  Right now only BricsCAD 17 will work with CADWorx 2018. 

When you download from bricsys.com, go to "Show Old Releases" to get the v17 installer.
image



George Montgomery, EIT 
Technical Support Manager
P 713.623.1502 C 832.993.8095

Important Disclaimer: All design information provided is for software support and informational purposes only. ECE Design takes no responsibility without written authorization to provide such information. No response to this email after 2 days will result in the closing of this case. Important Confidentiality Note: This E-mail message may contain privileged or confidential information. The information included in this E-mail is intended only for the person or entity to which it is addressed. Any use of this information by persons or entities other than the intended recipient is prohibited. If you receive this transmission in error, please delete this E-mail and destroy any copies of it.